That did the trick Chris. Thanks!

On Fri, Jan 10, 2020 at 3:30 PM Chris Guikema <> wrote:



Can you do a readelf of your outputted image to make sure its not compiling as a binary? If it is, you’ll have to use the “go” command in u-boot instead.



Chris Guikema




From: Devel <> On Behalf Of Mike Clark
Sent: Friday, January 10, 2020 3:22 PM
Subject: [seL4] Problem booting camkes arm vmm on TK1 from SD Card


CAUTION: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

I'm using the docker image to build the CAmkES ARM VMM project using roughly the instructions here: (they are slightly out of date).


I do: 





Then I copy the resulting image from the images directory to an SD card and put that in my TK1.


When U-Boot starts I use the following commands to try to boot


fatload mmc 1 0x10000000 capdl-loader-image-arm-tk1

bootelf 0x10000000


To which I get an error: No elf image at address 0x10000000


I tried with an older version of U-Boot (that worked following this same procedure about a year ago). It is U-Boot SPL 2014.10-rc2-g3127911 (Jun 07 2016 - 21:00:01)


I also tried updating U-Boot to U-Boot SPL 2020.01-00442-gc00bd81ae0 (Jan 10 2020 - 11:10:18 -0500). Same error.


Any thoughts or suggestions on how I get this to boot?