Hello all,

I am trying to have my own seL4 demo on Sabre Lite board. 
I am using this command to create the image file: 
 ../init-build.sh -DPLATFORM=sabre -DCROSS_COMPILER_PREFIX=arm-linux-gnueabi- -DCAMKES_APP=adder 

After that I run this commands to boot the image:

fatload mmc 1 0x41000000 adder(image file)

The bootm command gives this error:

Wrong Image Format for bootm command

ERROR: can't get kernel image!

I tried bootelf but it stuck and does not show the correct answer:

 bootelf 0x41000000

CACHE: Misaligned operation at range [10598000, 105980a4]

CACHE: Misaligned operation at range [10599000, 105a3434]

CACHE: Misaligned operation at range [105a3434, 105a3c23]

CACHE: Misaligned operation at range [107fc000, 1080a038]

## Starting application at 0x10598000 ...

ELF-loader started on CPU: ARM Ltd. Cortex-A9 r2p10


No DTB passed in from boot loader.

Looking for DTB in CPIO archive...found at 1069c064.

Loaded DTB from 1069c064.


ELF-loading image 'kernel'




ELF-loading image 'capdl-loader'




ELF loader relocated, continuing boot...

Enabling MMU and paging

It seems It does not go to kernel-image entry point and bootstrap the kernel!
Is there any thing that I need to perform on board?

Thank you,
Parvaneh Aghajani.