Looks like I might have spoken too soon. When I use go instead of bootelf, the board actually resets. Here are the log messages:

Tegra124 (Jetson TK1) # fatload mmc 1 0x82000000 capdl-loader-image-arm-tk1
20435184 bytes read in 964 ms (20.2 MiB/s)
Tegra124 (Jetson TK1) # go 0x82000000
## Starting application at 0x82000000 ...
data abort
pc : [<82000110>]          lr : [<fff51d84>]
reloc pc : [<021c3110>]    lr : [<80114d84>]
sp : fd7f8610  ip : 00000002     fp : fff6be40
r10: 00000002  r9 : fd7ffed0     r8 : fffcbe9c
r7 : fda60420  r6 : 82000000     r5 : 00000001  r4 : 00000000
r3 : 82000000  r2 : fda60424     r1 : fda60424  r0 : 00006090
Flags: nzCv  IRQs off  FIQs off  Mode SVC_32
Code: 00000000 00000000 00000000 42100040 (7865742e)
Resetting CPU ...

resetting ...

U-Boot SPL 2020.01-00442-gc00bd81ae0 (Jan 10 2020 - 11:10:18 -0500)
Trying to boot from RAM

U-Boot 2020.01-00442-gc00bd81ae0 (Jan 10 2020 - 11:10:18 -0500)

SoC: tegra124
Reset cause: SW_MAIN
Model: NVIDIA Jetson TK1
Board: NVIDIA Jetson TK1
DRAM:  2 GiB
MMC:   sdhci@700b0400: 1, sdhci@700b0600: 0
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  0
Tegra124 (Jetson TK1) #

Doing readelf on the image that is being built doesn't work either

$ readelf -h capdl-loader-image-arm-tk1
readelf: Error: Not an ELF file - it has the wrong magic bytes at the start

My old images from a year ago still boot just fine with bootelf. Any thoughts?


On Fri, Jan 10, 2020 at 3:46 PM Mike Clark <> wrote:
That did the trick Chris. Thanks!

On Fri, Jan 10, 2020 at 3:30 PM Chris Guikema <> wrote:



Can you do a readelf of your outputted image to make sure its not compiling as a binary? If it is, you’ll have to use the “go” command in u-boot instead.



Chris Guikema




From: Devel <> On Behalf Of Mike Clark
Sent: Friday, January 10, 2020 3:22 PM
Subject: [seL4] Problem booting camkes arm vmm on TK1 from SD Card


CAUTION: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

I'm using the docker image to build the CAmkES ARM VMM project using roughly the instructions here: (they are slightly out of date).


I do: 





Then I copy the resulting image from the images directory to an SD card and put that in my TK1.


When U-Boot starts I use the following commands to try to boot


fatload mmc 1 0x10000000 capdl-loader-image-arm-tk1

bootelf 0x10000000


To which I get an error: No elf image at address 0x10000000


I tried with an older version of U-Boot (that worked following this same procedure about a year ago). It is U-Boot SPL 2014.10-rc2-g3127911 (Jun 07 2016 - 21:00:01)


I also tried updating U-Boot to U-Boot SPL 2020.01-00442-gc00bd81ae0 (Jan 10 2020 - 11:10:18 -0500). Same error.


Any thoughts or suggestions on how I get this to boot?