Thanks Peter and Ben for your help previously. Cloning the libboost repository worked. Can someone explain to me the I am getting an error saying that it does not exist. Is there another repository that I have to clone to get the file?

After I input "make", I get this error:

/home/bryan/camkes-vm/tools/camkes/ /home/bryan/camkes-vm/build/x86/pc99/vm/ No such file or directory
While transforming AST: /home/bryan/camkes-vm/apps/vm/vm.camkes:4: unresolved reference to VM
make[1]: *** [/home/bryan/camkes-vm/build/x86/pc99/vm/] Error 255
make[1]: *** Deleting file `/home/bryan/camkes-vm/build/x86/pc99/vm/'
make: *** [vm] Error 2


On Fri, Nov 13, 2015 at 3:44 PM, Ben Karel <> wrote:
Perhaps it's referring to ?

On Fri, Nov 13, 2015 at 6:26 PM, Bryan Ching <> wrote:

So using repo did the trick. When I'm trying to build it, I'm getting an error involving libboost. Here is the error:
make: *** No rule to make target `libboost', needed by `vm'.  Stop.

I tried using the command, sudo apt-get install libboost-all-dev, to install all the boost packages. Does anyone have any ideas what's wrong?


On Thu, Nov 12, 2015 at 2:14 PM, Peter Chubb <> wrote:
>>>>> "Bryan" == Bryan Ching <> writes:

Bryan> I was just wondering for the CAmkES-vm, where is the Makefile
Bryan> to build it?  Also, to clone the github repository, do I use
Bryan> "repo" or can I use "git clone"?

Use repo; it should set up the Makefile for you from a different
repository (camkes-tool.git).  The starting point for the X86 VMM is
the camkes-vm manifest repository,

Peter C

Dr Peter Chubb                            Software Systems Research Group/NICTA/Data61

Devel mailing list